Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[tool_crash] _TypeError: (#0 IsolateManager.initialize.<anonymous closure> (package:dds/src/isolate_manager.dart:241:32)) #111926

Closed
jonahwilliams opened this issue Sep 19, 2022 · 10 comments
Labels
P4 Priority 4 issue (default for bugs, things we're likely to work on) severe: crash Stack traces logged to the console. tool Affects the "flutter" command-line tool. See also t: labels.

Comments

@jonahwilliams
Copy link
Member

jonahwilliams commented Sep 19, 2022

Command

flutter run -d windows --profile

Steps to Reproduce

  1. ...
  2. ...
  3. ...

Logs

_TypeError: (#0 IsolateManager.initialize. (package:dds/src/isolate_manager.dart:241:32))

#0      IsolateManager.initialize.<anonymous closure> (package:dds/src/isolate_manager.dart:241:32)
<asynchronous suspension>
#1      Mutex.runGuarded (package:dds/src/utils/mutex.dart:20:14)
<asynchronous suspension>
#2      IsolateManager.initialize (package:dds/src/isolate_manager.dart:217:5)
<asynchronous suspension>
#3      DartDevelopmentServiceImpl.startService (package:dds/src/dds_impl.dart:113:7)
<asynchronous suspension>
#4      DartDevelopmentService.startDartDevelopmentService (package:dds/dds.dart:97:5)
<asynchronous suspension>
#5     
@jonahwilliams
Copy link
Member Author

jonahwilliams commented Sep 19, 2022

This happened while running a windows desktop app in profile mode, the app in question is:

// Copyright 2014 The Flutter Authors. All rights reserved.
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.

import 'package:flutter/widgets.dart';

void main() =>
  runApp(
    Center(
      child:
        Image.network('https://pbs.twimg.com/profile_banners/284908325/1554440351/1500x500', loadingBuilder: (context, child, loadingProgress) {
          print('chunk!');
          return child;
        },)
      ),
    );

This may require the local changes I am testing, which are here: #111927

@jonahwilliams jonahwilliams added severe: crash Stack traces logged to the console. tool Affects the "flutter" command-line tool. See also t: labels. P4 Priority 4 issue (default for bugs, things we're likely to work on) labels Sep 19, 2022
@jonahwilliams
Copy link
Member Author

jonahwilliams commented Sep 19, 2022

@jonahwilliams
Copy link
Member Author

jonahwilliams commented Sep 19, 2022

This doesn't reproduce each time, but as a hint, this code is spinning up a temporary isolate.

@jason-simmons
Copy link
Member

jason-simmons commented Sep 20, 2022

This looks similar to #111482

The Dart DDS 2.3.0 package attempted to fix this, but it looks like it's still happening.

@bkonyi I think dart-lang/sdk@db6311b should be checking for a type instead of a kind

@bkonyi
Copy link
Contributor

bkonyi commented Sep 20, 2022

@bkonyi I think dart-lang/sdk@db6311b should be checking for a type instead of a kind

Agh, you're right. Fix up for review.

@bkonyi
Copy link
Contributor

bkonyi commented Sep 20, 2022

Fix is published as 2.3.1. This should be resolved (for real this time) once it rolls into the framework.

@christopherfujino
Copy link
Member

christopherfujino commented Sep 24, 2022

Even though greg's commit accidentally closed this, it should indeed be closed, as 2.3.1 has rolled to the framework: https://github.com/flutter/flutter/blob/master/packages/flutter_tools/pubspec.yaml#L13

@gspencergoog
Copy link
Contributor

gspencergoog commented Sep 24, 2022

@christopherfujino I'm sorry, but how did I accidentally close this? I haven't submitted anything to the SDK, and the referenced PR appears to be in my fork not the main repo, and there's only one auto-created PR in that fork that hasn't been submitted.

At about that time I did set up the build environment for the SDK on a machine and build it, but I just followed the setup instructions (and they don't include any pushing of PRs, AFAIK).

@gspencergoog
Copy link
Contributor

gspencergoog commented Sep 24, 2022

Oh, and I've never seen that commit before: I didn't author it.

@github-actions
Copy link

github-actions bot commented Oct 8, 2022

This thread has been automatically locked since there has not been any recent activity after it was closed. If you are still experiencing a similar issue, please open a new bug, including the output of flutter doctor -v and a minimal reproduction of the issue.

@github-actions github-actions bot locked as resolved and limited conversation to collaborators Oct 8, 2022
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
P4 Priority 4 issue (default for bugs, things we're likely to work on) severe: crash Stack traces logged to the console. tool Affects the "flutter" command-line tool. See also t: labels.
5 participants